Amp help

This is the place to ask questions about linear amplifiers, or power supplies.
Post Reply Previous topicNext topic
User avatar
BLACKMAGIC
Donor
Donor
Posts: 253
Joined: September 20th, 2006, 9:18 am
Age: 47
16

Amp help

#409605

Post by BLACKMAGIC »

I have an 8 pill that’s starting having issues. When talking with the 8 pill, and I let off the key sometimes my squelch is real low or none at all. Any idea? Thanks







Donate to CBRT
User avatar
Lost Ram
Donor
Donor
Posts: 1,094
Joined: September 22nd, 2009, 8:46 am
Age: 50
13

#409606

Post by Lost Ram »

Do you mean the receive is low?? Could be a weak relay or dirty relay contacts. That would be my first go to if its not all the time. You might even be sure the power supply is working as it should as well, If its having an issue regaining or keeping up after a key down it could be an issue there too.






CB: TRC-450, Imax
Ham: FTDX101MP, FT-991A ,FT8900-2 meter crossband rig
Ham Antennas: 570', 500', wire loops, 2M Copper Slim Jim X2, CG-144 mobile
"The two enemies of the people are criminals and government. So let us tie the second down with the chains of the Constitution so that the second will not become the legal version of the first."
Thomas Jefferson.

Donate to CBRT
User avatar
MDYoungblood
Verified
Site Admin
Site Admin
Posts: 10,523
Joined: June 12th, 2010, 8:05 pm
Age: 70
12

#409623

Post by MDYoungblood »

I would start with the basics, antenna, coax, connectors, etc., check all for possible rf leakage which would cause that problem. Lost Ram is also right about the relays, check them. The only other thing could be the transistor in the rf switch is going south.

3’s

Greg






"321, NW South Carolina"

Official Moderator - CBRT Complaint Department

Donate to CBRT
Post Reply Previous topicNext topic